帝国cms错误提示:Use of undefined constant can - assumed 'can'解决办法

MoBan5源码 | 2021-04-14 15:17:06 |
在使用php7版本以后,在安装 或者后台使用过程中经常会碰到 Warning: Use of undefined constant can - assumed 'can' (this will throw an Error in a future version of PHP) in...... 这样的错误提示。

这只是一个php版本的一个提示,实际使用过程中并不会有什么影响,php的一些无实际性错误的也会有提示。比如 7.1 、7.2、7.3等都会提示这个,安装过程和后台都会提示,虽然不影响使用,但是影响界面美观的操作性。

PHP的环境是可以关掉这种一般的错误提示的。只需要在PHP.ini环境中关掉 display_errors 就行了,On改成Off.

实际过程中使用宝塔碰到这个问题的人比较找,在软件管理中找到对应的PHP版本,设置 - 配置修改 - display_errors 选择关闭,再重启PHP就行了

例如修改php7.2版本中:

关闭错误提示方法